Possible fault Wi-Fi - Nebulae 2

Hi to all!

I recently purchased a Nebulae 2 and while it’s a really powerful module, I cannot obtain the wifi to work, even using the technobear alt firmware.
For debugging my module, i’ve connected the ethernet cable to my module and do a dmesg via Putty/SSH.

That’s the message about the wifi:

[ 14.155468] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
[ 17.757817] mmc1: Timeout waiting for hardware interrupt.
[ 17.757927] brcmfmac: brcmf_sdiod_ramrw: membytes transfer failed
[ 17.761952] brcmfmac: brcmf_sdiod_regrw_helper: failed to write data F1@0x100 0a, err: -5
[ 17.762034] brcmfmac: brcmf_sdiod_set_sbaddr_window: failed at addr: 0x1000a
[ 17.762091] brcmfmac: brcmf_sdiod_ramrw: FAILED to set window back to 0x18000 000
[ 17.762152] brcmfmac: brcmf_sdio_download_code_file: error -110 on writing 38 8739 membytes at 0x00000000
[ 17.762266] brcmfmac: brcmf_sdio_download_firmware: dongle image file downloa d failed
[ 17.766315] brcmfmac: brcmf_sdiod_regrw_helper: failed to write data F1@0x100 0e, err: -5
[ 17.766400] brcmfmac: brcmf_sdio_htclk: Failed access turning clock off: -5
[ 17.832006] brcmfmac: brcmf_sdiod_regrw_helper: failed to write data F1@0x100 0e, err: -5
[ 17.832094] brcmfmac: brcmf_sdio_htclk: HT Avail request error: -5

does someone have a problem similar to mine?

I discovered that could be a power not sufficient problem but i tried changing 12/5 switch and case supply and still that problem.
I contacted support also, patiently waiting for a response. :slightly_smiling_face:

Many thanks in advance to all!

Hi @Jumper981,

As far as I can remember, we had completely disabled wifi on the Raspberry Pi within the core nebulae builds.

The additions made by thetechnobear in his extended firmware expanded on the original firmware, and reenabled wifi, adding a number of features.

If you’ve updated, and followed the instructions on that page you should be able to use those additional features.
If you’ve done that, and you’re still unable to access it, you might have some luck searching the links he’s included on that page since it may have people with similar issues using that feature.

Hi, thanks for your response,
The ssh results it’s with the technobear firmware.
Also, the back of the wifi chip is a bit hot in this case. I also checked other raspberry oriented forums, and the error -110 refers usually to a hardware fault (signal integrity issue).
I have a friend with a Nebulae2 like me and he tried same steps like me but for him it’s currently working properly.
Could try his rpi3 on mine with my sd (or just my sd on his module), but i think it could void my warranty (please let me know if i could do one of those two options :wink: , I would greetly help to debug if possible).

I really tried everything as far as I know :sweat_smile: