No luck saving buffers or jumping octaves

Just got my Nebulae. Two questions:

I’m trying to save a recording made live to the Nebulae. The manual says press file and then freeze. I do this and it just freezes the buffer, but doesn’t save. What am I doing wrong?

Also, when I want to jump octaves, I push the speed knob and turn it. Nothing happens. Again, what am I doing wrong?

Hey, I wonder what causes problem Nr. 1, but holding down “file” and while doing so pressing “freeze” should normally work. (if the file-button as well as the freeze button are working in other modes, I would go the bruteforcing way of installing the firmware once again)

With the Nr. 2: Push the “Pitch”-Encoder instead of the “Speed”-Encoder to achieve octave-transpose. Should to the trick.

Hope it helped to sort at least one thing out.

Thanks for the response. I misspoke. I did push the pitch knob and turn it (while still pushing it). There is no octave jump.

As for the other issue, I updated the firmware, I think (green circling lights and all), but I still can’t get the file to save when I push and hold file and then push freeze. It just freezes. Not sure what to try next.

Thanks again for the help.

The Nebulae is very ‘time sensitive’ when it comes to short/long knob presses. Hold file and ‘very short’ pressing Freeze and releasing both File and Freeze, does this work?

ps. You can use the File button to normally cycle through files right, just to make sure the button works.

Hi. Thanks for responding. Yes, the file button works well for moving through files. And I’ve tried every length of press on freeze (with file held down). Still all that happens is it freezes.

Ok, now that you further explained what exactly you’re doing, I can’t see that much error in “human operation”. - I had some problems with my unit in the past until I just reinstalled the firmware and it was strangely gone (pointing out, that it was the exact firmware that has been on it beforehand).

What I’m also thinking: if pushed/ pressing operation of the speed and pitch encoder does work (you can try it with other operations like resetting the secondary-functions or just inverting the sample with pressing speed-encoder once for example) - you could at least say that the controls all work and just the “combo” does not, which would once again point into the direction of corrupt firmware (which in many cases still works regardless, but leaves out certain functions)

Mhm, just to ask a bit more: Do you use the USB-Stick supplied with the unit? - I doubt there’s anything wrong with it, if it reads, but just circling out everything that could be possible. - Only if you exceed the 75mb limit, the file will not be selectable, but at least you’d find it on the stick while hooking that to a computer. And this, I also doubt because then it would not freeze as well.

Can you confirm that your Nebulae is on v2.1.2? You can find out by looking at the neb_log.txt file on the USB drive.

There is a chance you are not on the most recent firmware, which added these two specific features.
If you aren’t on the latest firmware, you can find the latest firmware file on the Nebulae v2 product page.

Once downloaded, you will want to place the .zip file shown below onto your Nebulae v2’s USB Drive:

Make sure to extract the contents of the file before navigating and grabbing the file, or it will not work.

Boot up the module with the file on the USB Drive, and Nebulae will go through an update sequence that takes about a minute or so. After, your Nebulae will be up to date, and you should have access to those features!

Hi, thanks again. I think that may be the issue. It looks like the firmware may be factory reset (it looks like it’s v.1.0). I’ve tried several times to update, but, although it goes through the correct led cycle, it doesn’t seem to update (the problems persist, and I can’t see a record of the update on the neb_log file). Anyway, I’m in contact with someone at Qu-bit, so hopefully they can figure it out. Maybe it’s just an issue with the usb stick. Again, thanks for your help.

Ok, this is weird. I downloaded v2.1.2. I loaded it onto a new usb stick (in case the other was the problem). I started the booting of the Nebulae. All the leds did what they were supposed to. After powering down I removed the usb stick and checked it. There’s now a new neb_log file, and it seems to says

that I loaded v1_0_0. Not sure how this is possible…

Super strange! I reuploaded the firmware file onto the Nebulae product page, and cleaned up the zip folder so it should just be a single extract and one folder deep.

Let me know if the re-upload works for you!

Thanks again. All is well once I reformatted the sd card.

1 Like

Awesome! I’m glad that got it working.

Yes, the extra zip file folder was an issue when you were on v1.0.0 and moved to the latest v2.1.2 .
It did not traverse as the later versions did. Firmware zip file issue with Nebulae - #4 by Airell

1 Like

In addition to this, it seemed that there was a corruption issue with the previous update file hosted on the site. I tested the new file a couple of times now, and it is consistently working for me!