LEDs don't match on my 2 Nebulae v2

I have 2 Nebulae v2, both with Raspberry Pi3 in them. I had a problem with one that I solved by re-flashing the microSD card on the Pi. The only strange thing now is that after the boot sequence is over, the LEDs don’t match. One has both lower LEDs are Blue and the upper right is white, on the other one it lands on lower left Blue, upper right white with the lower right is off. They seem to SOUND the same. Is this indicating something? Is there a chart somewhere with the LED colors described?

I just forced an update to reload the same firmware into both units, through the USB stick and not by flashing the microSD card on the Raspberry Pi, and it seems to have worked. Both units display the same LEDs after boot, and act the same. All is well.
A thing to mention that isn’t said in the manual - you HAVE to rename the update file to neb_update.zip and it has to be the ONLY thing on the stick (NO log files even) to make it work. It was erased after it succeeded on the stick I used.

1 Like

I’m glad the update worked out! I’ll make a note to clarify the file naming conventions in the manual.

There is an issue with the latest firmware update zip file (not the SD image) and if you have a factory reset Neb to a v1.0.0. It doesn’t ‘dive’ into the .zip folders as a later version v2.x.x does. (Not to confuse with the Neb v2 hardware). Not sure if you did hit this at first firmware flash.

Also a recalibration should fix the ‘initial’ position of the LEDs. I had a brand new (rpi4) Neb last weak, with totally wrong initial ‘LED’ positions. Also pressing Speed or Pitch reset to the wrong values. After a recalibration it was ok again.

You can recalibrate by press and holding Pitch while turning the Nebulae on and release it when the LEDs turn yellow. I’m not sure if this is in the new manual, but it isn’t in the old one (which is still on the newest USB thumb drive).


1 Like