It’s incredible- a wholly new Nebulae, and it STILL will not record

Well, it took ten weeks, but I finally got a replacement v2 Neb, having sent a faulty one back to the retailer here in the UK in mid-November. Screwed it in, patched it up, refamiliarised myself with the workflow, and learned all over again that it’s a lot of fun. But then I tried to record something, and exactly the same thing happened as happened with the earlier module- it would not record, at all. However, remembering that I had finally had some success two or so months back, I revisited the thread and carefully followed my earlier workaround instructions.

Exactly the same thing happened this time too- so uncannily so that at first I thought that I’d simply been sent the old module back again. But no, this one is based on the RPi 4, not the 3. Yet it would not record unless the process above was followed to the letter, and (this is the bit that got to Michael first time around) the ‘Blend’ knob STILL produced silence at 12 o’clock, NOT the dry signal.

However, I still had recourse to the reformatting and reflashing instructions from November, and I spent half a day rewriting the sd card with the latest firmware and clearing unwanted files off the usb nubbin. And finally, after several hours on a MacBook, the ‘Blend’ knob finally produces the dry signal at 12 o’clock. Hurrah.

I’d like to say that I’m now happy with the module, but the following issues are still present:

  • Despite there being adequate headroom on the usb thingy, saving sounds to it is a very hit and miss process- an average of one out of three so far;
  • Clicking, or pushing and turning, the pitch and speed knobs does not have any of the reset or octave functions promised in the manual;
  • The pitch knob itself is very hard to turn in sections of its arc. A bent pot shaft or a badly formed knob- who knows. This is clearly a mechanical issue though.

I’d also like to add that the usb nubbin is too power-hungry to be read by an iPad. This is a bit of a pity, as the recording issue could be completely sidestepped if I could write to the usb from the iPad’s Files app. Unfortunately there is no equivalent to the Files app for Mac (why, Apple- why?), and there is therefore no way of simply dropping interesting wav files onto the usb from Dropbox or Audioshare as I could using the iPad.

All that said, the Neb is a terrific module, and I’m having a lot of fun with it. I’m just going to have to live with its shortcomings and its deviations from expected behaviour. Oh, and its not inconsiderable drain on the +12V supply has forced the purchase of a boost brick for the uZeus so that it can share a skiff with more than three or four other modules; the manual promises a toggle switch for a 5V option, but there isn’t one!

What firmware version are you using?

The latest, pulled from the QuBit site yesterday.

Hey @RtB, if you have a Pi4 Nebulae, then you do not need to update the firmware as it’s already on v2.1.2.

the manual promises a toggle switch for a 5V option, but there isn’t one!

You should be able to find the switch to toggle the 5V rail just behind the Nebulae logo on the control board! You can see it in the below image for reference:

There is a chance that the switch was bent, making it difficult to see. You would just need to bend it back in place. To the best of my knowledge, Nebulae shouldn’t power if this switch is uninstalled.

The Nebulae button combos are definitely tricky. The button presses should be fairly quick taps, almost like your finger is bouncing off the button. Here’s a video showing the difference with the SOURCE button:

You’ll notice in the first half that holding the button slightly longer will prevent the command from being read. But in the second half the button responds well to the swift tap.

This definitely should be working on your unit, with the most recent firmware. If you are still having issues with this, maybe we can try a knob recalibration. To recalibrate the knobs, hold down the PITCH encoder during boot up, until the LEDs turn yellow. This will recalibrate the knobs, and perhaps it will also bring back their intended functionality.

This, along with the encoders not working, would warrant another exchange in my book. If you continue to have troubles with your retailer, reach out to me direct and we can see what we can do.

1 Like

Thank you for your detailed response; apologies for the delay (long Covid…)

Well, I found the 5v switch. However, the recalibration of the knobs ended in disaster- the pitch knob still does nothing when pressed and turned that it doesn’t do when simply turned- and pressing and turning the speed knob seems to have bricked the module. I get three or four green lights, no sound whatsoever but a sine tone, and none of the five buttons now does anything. Turning it off and on again simply returns me to green lights and sine tones.

As I’m not sure that the retailer will stand for another return- and as they took ten weeks to replace the module last time- I would like to ship it to you in California for repair or replacement. Can you please advise my next steps.

Edit: I’ve fixed it- I think. I’ve replaced the 32gB SanDisk sd card I had been using since I received the new module with the 8gB original, and the green light/ sine tone issue has gone. However, pressing and turning the pitch knob still doesn’t get me an octave shift- and for obvious reasons I dare not press and turn the speed knob. I suspect that this may be as close as I’ll get to a functioning v2 Neb; I don’t seem to have had much luck so far. And yet I absolutely love what it does, even though it’s not firing on all cylinders.

Your thoughts would still be welcome. And if you think shipping it back to you will help, let’s go that way.

I wonder if your Nebulae had loaded an alternate instrument file, specifically the synth voice alternate instrument. I’m not by my Neublae to confirm, but you can check by holding the SPEED encoder down for three seconds, which will change the buttons over to the alternate instrument menu.

In this menu, all the SPEED and PITCH LEDs will be green. The bottom buttons will select what instrument to load.

Make sure that both SPEED LEDs are green by turning the encoder. This means the bottom buttons select the factory alternate instruments.

The RECORD button will select the default granular instrument. Press the button, then press the SPEED encoder to load the instrument.

RE 8GB SD card: make sure that that SD card and your Nebulae is on the most recent firmware (v2.1.2).

You can see what firmware you are running by looking at the neb_log.txt file on the USB drive. If you need to update, you can find the latest firmware on the Nebulae product page.