Firmware zip file issue with Nebulae

I wanted to post a question regarding the issue below, but I managed a workaround:

Whenever I copy the firmware .zip file specifically to the root of my USB stick I get this popup. It can only be removed by choosing for ‘cancel’, but it pops up every time I insert the USB stick into my W10 computer. In case anybody else runs into this issue:
Unzip the update .zipfile and rezip that file.

Hey @Veritosser, welcome to the forum! We’ve updated the file on the Nebulae v2 product page, and it should no longer throw this popup anymore :slight_smile:

Let me know if you have any other questions!


I haven’t checked firmwaring it, but you need to place the on the USB. Within the zip, the structure changed and there now is an extra folder in there, is this OK?


Thanks for responding @Airell, the idea was to put the solution I found up here for those who probably encountered the issue regarding this update. @michael recently updated the file, so it should work out by default now. It’s not completely clear to me if you are a user encountering this issue. If so, I urge you to try the new update file @michael renewed. If you’re still having the issue I mentioned, please notify me/us in this thread. Cheers

The additional folder shouldn’t cause any issues, and is just the result of re-zipping the file to prevent the pop-up window. Placing the new .zip file onto your Nebulae USB drive should behave as expected, but let me know if you still have issues with it!

It doesn’t work on mine, really, I’ve tried on two of my Nebs. I have reverted both to v1_0_0 and then it doens’t update. The new has too many folders and an extra zip and it’s not in the gzip format…

Take a look at the ‘old’ zip which does work: (download) → (this you put on the usb) → neb_update (firmware file)

But now (there are even an extra in between: (download) → Nebulae_v2_v2.1.2 (folder) → (zip no 1) → Nebulae_v2_update-rezipped (folder) → (zip no 2) → neb_update (folder) → neb_update (firmware file)

Which you put on the USB drive? Probably not the first, but the second doesn’t work either, there is a new folder in between second and the neb_update firmware file. Also when you leave this folder out, it still does not work when it’s in ‘the zip format’.

What I need to do is to unzip every zip (three!) take the plain neb_update (firmware file) then gzip it to (not the .gz extention but .zip) without a folder in between. For me it then works to update from v1_0_0 to Firmware updated to: v2_1_2

Cheers, Airell.

p.s. this link isn’t updated: (but maybe it’s not accessible anymore from links withing the site).

1 Like

Hello, Im trying to update my nebula pi 4 version back to firmware 2.1.2, I reverted to factory firmware and have tried using the various zip files given by the download button in the manual, also unzipping down to the main file and even looking at the enclosed folders and rezipping from the folder before the code folder. But the nebulae stays in firmware 1.0 version, is there any help or suggestions someone may have?

If you are having issues updating your Nebulae, I recommend reformatting the disk image back to 2.1.2.
You can follow the reformat instructions linked on the disk image page below!

Yes refreshing the sd worked, is this generally expected when using the revert to factory firmware file? Or should generally the 2.1.2 file work without re-flashing.

The update file on the product page should work fine, though it does require a couple steps to get to the file you need. If you:

  • download, then unzip the initial file
  • navigate the folders until you reach
  • place the file onto your Nebulae USB Drive
  • insert drive into Nebulae, and power cycle.

then Nebulae should update.

If the update process is not working as expected, reformatting the SD card is the surefire way to update Nebulae.

Reverting to factory v1.0 and update to v2.1.2 without unzipping the zip with 2.1.2 in it’s name first does not work. I have showed this in a previous post here somewhere. It has to do with the folder setup of the original zip and the way the v1.0 updates itself.

It however does work without unzipping to first if you are on a later version, but not when you are on the original v1.0 factory reset.

Tried this several time on both my nebs to figure out what’s going on…

Best is to unzip to and place that on the usb, for all versions.