Data Bender v3 vs v5 vs v1

Hi to everyone!
Dumb question: which are the differences between the 2019 (v1), 2020 (v3) and 2021 (v5) versions of the data bender?
I’m having some trouble updating my v3 and I’m asking myself if it’s a “version” related issue…
Thanks to everyone

Hey @aho98 welcome to the forum! The versions you are mentioning only refer to the production hardware revisions for Data Bender. Functionally, each version behaves the exact same, and revisions were made for manufacturing purposes. Updating your Data Bender will use the exact same files and methods across these versions as well.

Let me know if you need help troubleshooting the update, and I’d be happy to answer any questions!

1 Like

Hi Michael! Thank you so much for the reply!
I’m still stuck on updating the data bender: tried lots of different cables, different computers and other advices from the website but nothing worked at the moment.

1 Like

Interesting, and I assume you are following our tutorial video so you are doing the steps correctly. The most common issue is typically the USB cable, since some cables only transfer power and not data. Since the cables are not marked for this, it’s an easy issue to come up when trying to update.

If you’ve tried multiple cables, and cables that have definitely transferred data in the past, then there may be an issue with the Seed on the back of your module. Let me know if you can confirm your USB cables have worked as described above, and we’ll move forward with a solution!

1 Like

In the next few days, I’ll try other cables… I hope that’s the problem. Do you know any cables that could definitely work?
Thank you so much

If you weren’t able to find a cable that works, this cable will 100% work with Daisy: Micro USB cable — Electro-Smith

Since it is the official cable from the Daisy makers themselves, it should work just fine!

1 Like

Here are some other things to verify:

  1. Are you using an up to date version of Chrome?

  2. Does the power LED on the Daisy light up when you plug in a USB cable?

  3. Are you powering the Daisy from your Eurorack case while trying to update?

  4. Worth mentioning, USB cables are the single most common problem. Even if you have tried 4 cables, try a fifth!

1 Like

Hi to everyone!
Finally updated the Data Bender! Thanks so much to everyone. I’ve used a simple usb c - micro usb cable: I think that’s the problem was the usb c - usb adapter…

1 Like

Glad you were able to isolate the issue! Enjoy the update :slight_smile:

1 Like