Branches knob doesn't go to 1 branch

I’ve just received Bloom (the version with the little screw on the front panel, so I guess it’s the updated one).

I couldn’t just have a simple sequence play the way I wanted because it kept changing every time.
I figured out the problem is that when I zero the Branches knob by turning it CCW, the minimum value it reaches it’s 2 branches and not 1 (two leds instead of 1).

Does it have a wrong calibration on that knob?

I have the exact same issue with my newly purchased Bloom. Anyone have any ideas?

I solved the issue by re-flashing the firmware and doing the calibration after that.
The firmware fixed the issue with the knob but messed with the tuning. The calibration solved that.
Both procedures are in the manual and are quite straight forward

1 Like

@luca is right on this fix, but I’ll place the firmware and instructions here for reference!

Daisy Bloom firmware
QB_Bloom_v2_0_16.bin (102.3 KB)

To resolve the Branches issue, follow these steps:

  1. Update to the latest firmware. You can follow the same instructions used to update Data Bender here.
  2. With no CVs patched into the module, hold RESET on the Bloom when turning on your system.
  3. This will do a little green LED dance on the central four LEDs to indicate that the offsets of the CVs are properly calibrated.

And then you should be good to go!

Note: This update is only for a select number of Daisy Blooms afflicted with this issue. If you do not have this issue, or have an older hardware version of Bloom, you do not need to update.

1 Like