Cannot record anything into Nebulae at all

Sorry, probably doing something really dumb, but I cannot get Nebulae to record anything at all. I have audio going into in L and in R, and I’m sending a trigger to the Record input. The button lights white (NOT red) and goes out after a few seconds without any further trigger. Meanwhile, the outputs are playing the last audio file that was loaded as if nothing else was happening (it isn’t). Is that the issue? Should I be removing the USB? Clearing the buffer? (there are no clues in the manual as to how to do this). The only topics I can find on this forum concern circular recording, which seems to be another order of difficulty altogether- I’d just like to learn how to get sound into the module at this stage…

1 Like

You’ll need to press “Source” so that it is illuminated. Also, if you’re running the regular firmware, I think you might need the blend knob at 12 o’clock

Thanks for the advice, but that doesn’t work either. Tried a quick tap on the Source button but the Record light still lights white, the buffer keeps playing the same file, and nothing is recorded.

Duff module possibly?

Never try to tackle anything difficult late at night. With that in mind, I slept on the problem, came back to it this morning, and- despite the manual- managed to get Nebulae to record something, thus:

  • Remove USB stick

  • Power module on

  • Tap ‘Source’- it lights white

  • Connect sound source in ‘In L/R’, connect ‘Out L/R’ to mixer

  • Trigger ‘Record’- it lights white, while both ‘Speed’ indicators light red

  • Trigger ‘Record’ again to end recording

  • Play with the recorded sound


  • Do NOT turn ‘Source’ off, or anything still held in the buffer will play

  • The ‘Blend’ knob produces silence at 12 o’clock, NOT the dry signal

The fact that every step of the process above either contradicts what is shown in the manual for v2.1.2- or does not appear in the manual at all- suggests that I have a completely different firmware, despite what the USB stick is telling me. Or perhaps, as per my previous post, the module is faulty- I recall that there is mention elsewhere on the Forum of red ‘Speed’ lights indicating an error, but in my case they indicate that the module is, finally, recording.

Please advise. The retailer from whom I bought the module has a shorter return window than some, and while I am aware of the QuBit ‘warranty in perpetuity’, I would rather have this resolved in the UK than by sending the Nebulae to California.

I’m still new to nebulae but I had similar issues, I solved by redoing firmware which you can check version on usb I believe there’s a log file.

After I updated, I had noticed on mine the back circuit board had come a little loose so I pushed it together and it was working afterwards. But had weird behavior before I found that. Hopefully it’s something easy for you.

If you do revert to factory firmware using the usb file, and try updating through usb, some of us had issues with the usb updater so I had to do the longer update process using the pi disk image from the website.

This should not be happening in Live Mode on the most recent firmware. I’ve attached a brief video for reference when using Live Mode to see if it matches your experience:

If it does not, I recommend re-formatting the SD card for your Nebulae hardware version (Pi3 or Pi4).

The only other thing I could think of that would cause this is if your input level is all the way down, but that would result in recording silence, and you would hear no sound when live recording.


I have tried to attach a video but the Forum doesn’t like the file format (it’s just a 30s video shot with an iPhone 6). However, there is definitely no sound at all with the Blend knob at 12 o’clock; any position cw or ccw produces sound.

I am baffled by your Pi3/Pi4 references- does this refer to recoding or reflashing in any way? I am very reluctant to make software changes to the module as it seems more and more likely that it will have to be returned to the retailer as faulty- and I would rather not take the risk of doing so having corrupted/ wiped the sd card.

In order to keep Nebulae v2 in production, we made a hardware revision that uses a Raspberry Pi 4, since the Pi 3 version has been deprecated.

Both versions of Nebulae behave the exact same, you just need to know which Raspberry Pi is on the back of your Nebulae only before reformatting the SD card. You can update either version via the USB Drive and using the same firmware.

Here’s a link to a page showing the difference between the two: Which Nebulae Do I Have? — Qu-Bit Electronix

Without looking again, it’s the Pi 3. I remember seeing the HDMI port when I was checking whether it had USB-C or not, and thinking “this thing has video?”

So do you recommend simply trying to reformat the sd card, or flashing to firmware to the Neb again as well? I’m still rather concerned- whatever the text on the usb says- that the behaviour of the module does not match that described in the manual, which claims to be for v2.1.2.

For more enigmatic issues like this one, I recommend reformatting the SD card, since it also updates the firmware. It’s typically about a 15-20 minute update. I also recommend booting up with the factory sample files on the USB Drive, to avoid any potential issues on that front.

If the SD card formatting doesn’t resolve the issue, then I would recommend exchanging the unit with your retailer, or sending in an RMA inquiry with us!

Is there a guide anywhere as to how I would go about formatting the sd card in the context you’re using? My understanding has always been that ‘formatting’ a card is simply preparing a new, blank card for first use. The sense in which you’re using the word suggests to me writing the entire software to the sd card, but there’s no clue in the manual, or on the Forum, as to where this can be sourced, or how it is done. I refer you to my comment above, to the effect that as the module is almost certainly faulty the last thing I should be doing is erasing the sd card, which is what you appear to be suggesting. The only thing I have gathered from the Forum is that I ought to replace the sd card with one of a good name and a decent capacity, but this still leaves the issue of where I would source the replacement code.

Halfway through the return window…

On the Pi3 disk image page, you can download the disk image, then click the link to the page with instructions on how to reformat your SD card. I’ve also placed the links here to use as well:

Download the Pi3 Disk Image

How to reformat your SD card

If the reformatting doesn’t work, and you miss your return window, just let me know and we’d be happy to do a direct exchange for a new unit!

That, eventually, went rather more quickly than you had suggested. It did take around an hour to download the installer and the firmware, but once that was done the actual process took less than five minutes, and was so smooth that I did the same thing again with a SanDisk 32GB sd card as recommended elsewhere on the Forum.

That’s the good news. The bad news is that the ‘Blend’ knob STILL produces silence at 12 o’clock, not the dry signal. Given that the sd card has been sorted and v2.1.2 reinstalled, what could be the issue now?

Hmm, I’m surprised that the reformatting did not work. At this point, we may want to look at your unit in our shop to diagnose any potential hardware issues that could cause this (I’m not sure what that would be, since Nebulae is receiving audio if you are able to still hear the recorded live input).

You can either:

  • return/exchange the unit with your retailer if you are still in the warranty window, or
  • Do a direct exchange with us if you are in the USA. I can provide details in a DM if you prefer this route.

The retailer is now out of stock, so an immediate replacement is out of the question. Moreover, as the Neb is pretty much the only granular instrument with separate control over pitch and speed, a refund is not really an option either…

I’ll email the retailer and direct them to this thread on the Forum. At least that will have officially registered- with both manufacturer and retailer- that there is an issue with the module.

The retailer has the Neb back. Still no new stock, so not replaced, yet.

Meanwhile I have bought a Mojave from another dealer. Have I done the right thing? If I ever get both in the rack I’ll find out…