Can Nebulae (v2) fire a single grain?

I assume there’s some way to send Nebulae a trigger which will fire a single grain with parameters based on size and start but for the life of me I can’t figure out how.

Anyone have any ideas? Sorry if this is totally obvious.

Hey @mattcolville, welcome to the forum! You can fire a single grain by swapping out the Source Gate input functionality. Hold down the Source button, and press the Freeze button to change the Source Gate input to be a grain gate input. You’ll know if it’s active when the Freeze LED is lit while holding down Source.

With density fully counter clock wise, each gate signal into Source will trigger the grains, letting you send gate sequences to Nebulae to create rhythms within your granular processing. Note that if Density is up, Nebulae will both automatically trigger grains based on the density settings, and will still include any gates sent to the Source input when this mode is active.

Let me know if this helps and if you have any more questions!

1 Like

Awesome! Thanks for the reply, I’ll try it out. :smiley:

Hi Michael, I have tried your suggestion but just can’t seem to get this work. Is it related to firmware and how can I check which firmware I am using? I only recently purchased the V2.

Are any grains firing at all(Density anywhere but fully CCW)? If not, maybe your blend knob is in the vocoder position?

Thanks for speedy response! Yes indeed, blend knob was in the vocoder position, but also density at fully CCW does not seem to have the desired effect. I played around with density, overlap etc until I got something working how I wanted. Nice to get this working and a great feature.

At that point, it seems like the source input hasn’t been switched over. Try holding Source and then pressing Freeze as @michael had instructed “Hold down the Source button, and press the Freeze button to change the Source Gate input to be a grain gate input. You’ll know if it’s active when the Freeze LED is lit while holding down Source.”

Hope this helps!

1 Like

I have this working.The main thing seems to be playing with the overlap to get anything other than a tiny click triggering from the source gate.

Yeah, was confused when I first tried this mode. Overlap has a fixed grain-size-range in that mode :wink:

Would the Size knob control this? It’s my understanding that the Start/Size would control how long the grain is, and Overlap would just control how many grains can play at a time. I haven’t tested this, but that’s how I assumed it worked from day one even in the regular mode

No, not really: the Start and Size are the lengthcomtrols for the complete Audioloop - Start says where to pick up the loop and Size how much of the loop is played in total (look at the manual for seeing how that relates in this case).

With Density, you control the speed of grain-generation and with Overlap, you control the size of those grains. In the Gated-Grain mode the Density controls „automatic generation of grains“ adding to the ones you‘d trigger externally, while the Overlap is changed to fixed sizes in a range from 500ms to 2s per grain fired.

It‘s all well embedded in the newer manual.

1 Like

@The_Monotonist You’re right that it doesn’t specifically say it in the manual. But the secondary function implies that the Start knob selects the start location of the audio file as well as where the grain in the audio buffer fires.

Page 15
"Secondary Function: Grain Position

Holding down the Source button and turning the Start knob will add random probability to where
new grains are generated from.

When the knob is fully CCW, new grains will only generate from the playback position. As the
knob is turned CW, the chance increases for new grains to generate from a random position in
the audio loop. When the knob is fully CW, all grains are generated from a random position in
the file or buffer."

I am indeed wrong about the Size knob. As you said, Overlap controls that.

I also saw that Overlap’s Secondary function adjusts the Size deviation.

"Holding down the Source button and turning the Overlap knob controls the amount of random
deviation applied to each grain size. When the knob is fully CCW, no random deviation is applied
to the grain size. As the knob turns CW, the probability and amount of random deviation to grain
size increases for each grain. When the knob is fully CW, each grain receives a random length
adjustment of -/+ 100%. "

I wonder if this still applies in the Source Input mode. Something to play with @lostorca

Yes, the secondary mode of certain controls make it ominous a bit. It takes some time to see where the primary heavily differs from the secondary. With the secondary overlap function set up (which I did not try yet), I could imagine that the random size-setting would not be applied to the “fixedness” of the overlap in “grain-trigger-mode” (?) - In my usecases, I happen to patch the cv-inputs more than applying the secondary modes, because I always forget about the settings and then go on wondering as to why my samples are so f**k’d up all of a sudden :smiley:

1 Like


I’m the opposite. I almost exclusively use the secondary functions instead of CV. Mainly to try and commit them to memory. But I should patch more… That is when I go back to the granular engine. I’ve been exploring the alternate instruments more recently.

Is it normal operation that every other trigger triggers a grain? A grain won’t get triggered by every incoming trigger in my case, its more like its toggling between the two sources resulting in a audible grain every other incoming trigger

Mhm, sounds not “normal”, BUT: It depends on your source-sample and the size of your overlap and the speed of the triggers.

  1. If your source has some silent parts, the grains will most certainly picked up somewhere over there so you don’t hear “the nothing” play.
  2. If your overlap is set really small, it would maybe hit one of the aforementioned deadspots in the sourcesampler
  3. I noticed that at higher rates, the Nebulae does not fire consistently - I saw that behaviour in the One-Shot-Sampler-FW first, especially at “hihat-range”.

And a lost, more abstract thought: depending on other settings in the secondary menu, these might result in some hits not firing at all by the functions that are engaged. Try resetting the secondary functions once by…I think it was “Source + Speedencoder” (?) and try if it still appears to miss.

the sample has no silent parts, it behaves like people who claps on one and three :face_with_raised_eyebrow: perhaps I’ve failed to even get that mode enabled so it just switches between the sources :thinking:

1 Like

Can you confirm that you’re in the Source Gate Input Trigger mode?

Hold Source and press Freeze. Now, whenever you hold Source, the Freeze button should be illuminated.

Your issue seems similar to one I had where it was actually switching between the Sample and the Audio In (with nothing patched) which resulted in every other trigger being silence. I brain-farted and was pressing Source + File instead of Freeze so I was never actually in the Source Trigger mode :sweat_smile: Much like you mention in the post above this one.

Im fairly sure that freeze is illuminated when I hold source, I’ll check it when I get home tomorrow!