Bloom doesn't reset

I’m having some issues with my bloom. It seems that when I want to reset a sequence it always after a couple of cycles through goes on a tangent and creates its own notes, I have everything set to 0 so nothing is being mutated or branched. Feel like it’s always been playing up a bit.


hi! i am new to bloom and have the same problem.


Hey @mojo9210, welcome to the forum! A quick troubleshoot we can try is turning the Mutate knob all the way up, then all the way back down.

The knobs on Bloom have persistent memory, so sometimes when a knob was in a different state in one menu, and changes in another, the value outputted from the knob might not match the knob position until you update it with CV or a knob turn.

1 Like

Same problem here. I am clocking Bloom with a 1x clock from Pams and tried to reset it with a start pulse or end pulse, or manually with the button. Sometimes it starts with Pams, but often there are several cycles before the start, or it even skips the first note.
I did not try to turn the mutate knob up and back again. Will do that and get back.

Hey, I think these are two different meanings of “reset” here in the topic:
The “Shit+Reset-Button”-combo resets the variations of a sequence while said gate/trigger will set the sequence to the first step.

With the latter target of reset, I have that “combo”, too. I am not sure, if that helps, but have you looked at the resolution of the internal counter of the Bloom? - You can set that at multiplication or division of counts, so especially if the Bloom-channel is internally set to multiply or divide the speed, it might act up while resetting. - Think of Pamela sending 120 BPM which are then calculated to “240” BPM in the Bloom or “60” - a reset might fall wrong for your sequence.

Also, with the Bloom as well as some other sequencers, the “quality” of the Trigger/ Gate (clocking as well as resetting) is crucial. Have you - just to check possibilities - checked with another source for reset, and if so: does the same happen here?

Best regards

1 Like

@the Monotonist: you are right! I was refering to the clock reset, not the sequence. My fault, did not read mojo9210 post properly.
In the meantime I solved my problem: I checked the firmware version on my bloom, which was the latest (1.0.6). Still I checked the firmware download for a hint and I found this:

Hold SHIFT + LENGTH while the module boots up. This will restore all calibration data to the factory default (Calibration mode can still be reached if you want to fine tune the calibration). Upon booting, the LEDs will cycle between blue and gold for three seconds to indicate that the data has been restored.

After the restoration of the calibration data, my bloom resets the clock like it should. Problem solved, life goes on as it should. :wink:

Maybe that helps with the other reset problem as well.

1 Like

Thanks for all the responses iv been in contact with qubit and have now flashed the module with the latest FireWire which seems to have fixed my issues

1 Like

@mojo9210: :+1:
My reset problem came back as soon as I entered a new sequence and used the module for a new jam. So no real solution here.

Thanks :+1: this was my problem.

I am having the above described clock resetting issue (not the thing with the notes) , and the recommended fix does not help. My expected behavior is that when bloom is receiving no clock pulses, then I hit reset , at the first clock pulse it will play the sequence from the first note steadily. This is how it behaves when I have blooms clock divisions on beat with the clock pulse. But if I change to a faster clock division, bloom will play the first note and then hiccup before playing the rest of the sequence, pushing the whole sequence out of time. Not sure if this is a bug, or if it’s intended and bloom needs a reset trigger at the start of the sequence